If you are preparing for CCNP TSHOOT exam to get the Cisco CCNP certification, you may want to know how to configure the TSHOOT IPv4 Layer 3 Topology. I tried to figure out the IPv4 Layer 3 Topology configuration and now I share it to you. I hope you find it useful.
If you are interested in this topic, you can learn more by reading this article: TSHOOT IPv6 topology configuration.
ip access-list standard edge_security
permit 209.65.22.224 0.0.0.3
!
ip nat inside source list 1 int s0/0/1 overload
!
interface loopback 0
ip address 1.1.1.1 255.255.255.255
int s0/0/1
ip address 209.65.200.225 255.255.255.252
ip access-group edge_security in
ip nat outside
!
int s0/0/0
no ip address
encapsulation frame-relay
int s0/0/0.12 point-to-point
ip address 10.1.1.1 255.255.255.252
ip nat inside
ip osfp authentication message-digest-key 1 md5 4af57e43
frame-relay interface dlci 102
router bgp 65001
no synchronization
bgp log-neighbor-changes
network 209.65.200.225 255.255.255.255
neighbor 209.65.200.226 65002
no auto-summary
router ospf 1
network 10.1.1.0 0.0.0.3 area 12
redistribute bgp remote-as 65001 metric 100 subnets
area 12 authentication message-digest
ip address 2.2.2.2 255.255.255.255
int s0/0/0
no ip address
encapsulation frame-relay
int s0/0/0.12 point-to-point
ip address 10.1.1.2 255.255.255.252
ip osfp authentication message-digest-key 1 md5 4af57e43
frame-relay interface dlci 201
int s0/0/0.23 point-to-point
ip address 10.1.1.5 255.255.255.252
frame-relay interface dlci 203
router ospf 1
network 10.1.1.2 0.0.0.3 area 12
network 10.1.1.4 0.0.0.3 area 0
area 12 authentication message-digest
ip address 3.3.3.3 255.255.255.255
int s0/0/0
no ip address
encapsulation frame-relay
int s0/0/0.23 point-to-point
ip address 10.1.1.6 255.255.255.252
frame-relay interface dlci 302
int s0/0/0.34 point-to-point
ip address 10.1.1.9 255.255.255.252
frame-relay interface dlci 304
router ospf 1
network 10.1.1.4 0.0.0.3 area 0
network 10.1.1.8 0.0.0.3 area 34
ip dhcp pool VLAN10_POOL
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
interface loopback 0
ip address 4.4.4.4 255.255.255.255
int s0/0/0
no ip address
encapsulation frame-relay
int s0/0/0.34 point-to-point
ip address 10.1.1.10 255.255.255.252
frame-relay interface dlci 403
router eigrp 10
network 10.0.0.0
passive-interface s0/0/0
redistribute ospf 1 metric 10000 100 255 1 1500 subnets route-map OSPF2EIGRP
no auto-summary
route-map OSPF2EIGRP 10
match prefix-list PFL_OSFP2EIGRP
ip prefix-list seq 5 PFL_OSFP2EIGRP permit 209.65.200.224/30
ip address 10.1.4.6 255.255.255.252
ip helper-address 10.1.4.5
interface f1/0/2
ip address 10.2.4.13 255.255.255.252
interface f1/0/3
switchport mode access
switchport access vlan 10
interface f1/0/4
switchport mode access
switchport access vlan 10
router eigrp 10
network 10.0.0.0
no auto-summary
interface vlan 10
ip address 10.2.1.1 255.255.255.0
interface vlan 20
ip address 10.2.2.2 255.255.255.0
ip address 10.1.4.10 255.255.255.252
interface f1/0/2
ip address 10.2.4.14 255.255.255.252
interface f1/0/3
switchport mode access
switchport access vlan 20
interface vlan 10
ip address 10.2.1.2 255.255.255.0
interface vlan 20
ip address 10.2.2.1 255.255.255.0
router eigrp 10
network 10.0.0.0
no auto-summary
This configuration can help you to prepare for the Cisco TSHOOT exam. Please, if you see any
mistake, let me know.
If you are interested in this topic, you can learn more by reading this article: TSHOOT IPv6 topology configuration.
R1
access-list 1 permit 10.2.1.0 0.0.0.255ip access-list standard edge_security
permit 209.65.22.224 0.0.0.3
!
ip nat inside source list 1 int s0/0/1 overload
!
interface loopback 0
ip address 1.1.1.1 255.255.255.255
int s0/0/1
ip address 209.65.200.225 255.255.255.252
ip access-group edge_security in
ip nat outside
!
int s0/0/0
no ip address
encapsulation frame-relay
int s0/0/0.12 point-to-point
ip address 10.1.1.1 255.255.255.252
ip nat inside
ip osfp authentication message-digest-key 1 md5 4af57e43
frame-relay interface dlci 102
router bgp 65001
no synchronization
bgp log-neighbor-changes
network 209.65.200.225 255.255.255.255
neighbor 209.65.200.226 65002
no auto-summary
router ospf 1
network 10.1.1.0 0.0.0.3 area 12
redistribute bgp remote-as 65001 metric 100 subnets
area 12 authentication message-digest
R2
interface loopback 0ip address 2.2.2.2 255.255.255.255
int s0/0/0
no ip address
encapsulation frame-relay
int s0/0/0.12 point-to-point
ip address 10.1.1.2 255.255.255.252
ip osfp authentication message-digest-key 1 md5 4af57e43
frame-relay interface dlci 201
int s0/0/0.23 point-to-point
ip address 10.1.1.5 255.255.255.252
frame-relay interface dlci 203
router ospf 1
network 10.1.1.2 0.0.0.3 area 12
network 10.1.1.4 0.0.0.3 area 0
area 12 authentication message-digest
R3
interface loopback 0ip address 3.3.3.3 255.255.255.255
int s0/0/0
no ip address
encapsulation frame-relay
int s0/0/0.23 point-to-point
ip address 10.1.1.6 255.255.255.252
frame-relay interface dlci 302
int s0/0/0.34 point-to-point
ip address 10.1.1.9 255.255.255.252
frame-relay interface dlci 304
router ospf 1
network 10.1.1.4 0.0.0.3 area 0
network 10.1.1.8 0.0.0.3 area 34
R4
ip dhcp excluded-address 10.1.2.1 10.1.2.2ip dhcp pool VLAN10_POOL
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
interface loopback 0
ip address 4.4.4.4 255.255.255.255
int s0/0/0
no ip address
encapsulation frame-relay
int s0/0/0.34 point-to-point
ip address 10.1.1.10 255.255.255.252
frame-relay interface dlci 403
router eigrp 10
network 10.0.0.0
passive-interface s0/0/0
redistribute ospf 1 metric 10000 100 255 1 1500 subnets route-map OSPF2EIGRP
no auto-summary
route-map OSPF2EIGRP 10
match prefix-list PFL_OSFP2EIGRP
ip prefix-list seq 5 PFL_OSFP2EIGRP permit 209.65.200.224/30
DSW1
interface f1/0/1ip address 10.1.4.6 255.255.255.252
ip helper-address 10.1.4.5
interface f1/0/2
ip address 10.2.4.13 255.255.255.252
interface f1/0/3
switchport mode access
switchport access vlan 10
interface f1/0/4
switchport mode access
switchport access vlan 10
router eigrp 10
network 10.0.0.0
no auto-summary
interface vlan 10
ip address 10.2.1.1 255.255.255.0
interface vlan 20
ip address 10.2.2.2 255.255.255.0
DSW2
interface f1/0/1ip address 10.1.4.10 255.255.255.252
interface f1/0/2
ip address 10.2.4.14 255.255.255.252
interface f1/0/3
switchport mode access
switchport access vlan 20
interface vlan 10
ip address 10.2.1.2 255.255.255.0
interface vlan 20
ip address 10.2.2.1 255.255.255.0
router eigrp 10
network 10.0.0.0
no auto-summary
This configuration can help you to prepare for the Cisco TSHOOT exam. Please, if you see any
mistake, let me know.
This comment has been removed by the author.
ReplyDelete