If you want to know how to configure the TSHOOT IPv4 Layer 2/3 Topology you are in the right place. In order to prepare for the CCNP TSHOOT exam to get the Cisco CCNP certification, I tried to figure out the IPv4 Layer 2/3 Topology configuration.
This is the third article of this series so, if you are interested in this topic, you can learn more by reading the TSHOOT IPv6 topology configuration.
encapsulation frame-relay
int s0/0/0.12 point-to-point
ip address 10.1.1.1 255.255.255.252
frame-relay interface dlci 102
int s0/0/1
ip address 209.65.200.225 255.255.255.252
router bgp 65002
no synchronization
bgp log-neighbor-changes
neighbor 209.65.200.226 65002
encapsulation frame-relay
int s0/0/0.12 point-to-point
ip address 10.1.1.2 255.255.255.252
frame-relay interface dlci 201
int s0/0/0.23 point-to-point
ip address 10.1.1.5 255.255.255.252
frame-relay interface dlci 203
encapsulation frame-relay
int s0/0/0.23 point-to-point
ip address 10.1.1.6 255.255.255.252
frame-relay interface dlci 302
int s0/0/0.34 point-to-point
ip address 10.1.1.9 255.255.255.252
frame-relay interface dlci 304
encapsulation frame-relay
int s0/0/0.34 point-to-point
ip address 10.1.1.10 255.255.255.252
frame-relay interface dlci 302
int f0/0/0
ip address 10.1.4.5 255.255.255.252
int f0/0/1
ip address 10.1.4.9 255.255.255.252
router eigrp 10
no auto-summary
network 10.0.0.0
ip address 10.1.4.6 255.255.255.0
interface f1/0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
interface f1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
interface f1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 14 mode on
interface f1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 14 mode on
interface f1/0/23
no switchport
no ip address
channel-group 12 mode on
interface f1/0/24
no switchport
no ip address
channel-group 12 mode on
interface vlan 10
ip address 10.2.1.1 255.255.255.0
standby 10 ip 10.2.1.254
interface vlan 20
ip address 10.2.2.2 255.255.255.0
interface vlan 200
ip address 192.168.1.129 255.255.255.224
ip dhcp excluded-address 10.1.2.1 10.1.2.2
ip dhcp pool DHCP_POOL
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
router eigrp 10
no auto-summary
network 10.0.0.0
ip address 10.1.4.10 255.255.255.0
interface f1/0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 24 mode on
interface f1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 24 mode on
nterface f1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
interface f1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
interface f1/0/23
no switchport
no ip address
channel-group 12 mode on
interface f1/0/24
no switchport
no ip address
channel-group 12 mode on
interface vlan 10
ip address 10.2.1.2 255.255.255.0
standby 10 ip 10.2.1.254
standby 10 priority 90
interface vlan 20
ip address 10.2.2.1 255.255.255.0
interface vlan 200
ip address 192.168.1.130 255.255.255.224
router eigrp 10
no auto-summary
network 10.0.0.0
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
interface f1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
interface f1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
interface f1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
int f1/0/1
switchport mode access
switchport access vlan 10
switchport port-security
int f1/0/2
switchport mode access
switchport access vlan 10
switchport port-security
ip access-list 10 permit 10.2.0.0 255.255.255.0
vlan access-map BLOCK_CLIENT1 10
action drop
match ip ACL_BLOCK_CLIENT1
vlan access-map BLOCK_CLIENT1 20
action forward
vlan filter BLOCK_CLIENT1 vlan_list 10
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 13 mode on
interface f1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 13 mode on
interface f1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 23 mode on
interface f1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 23 mode on
int f1/0/1
switchport mode access
switchport access vlan 20
This configuration can help you to prepare for the Cisco TSHOOT exam. Please, if you see any mistake, let me know.
This is the third article of this series so, if you are interested in this topic, you can learn more by reading the TSHOOT IPv6 topology configuration.
R1
int s0/0/0encapsulation frame-relay
int s0/0/0.12 point-to-point
ip address 10.1.1.1 255.255.255.252
frame-relay interface dlci 102
int s0/0/1
ip address 209.65.200.225 255.255.255.252
router bgp 65002
no synchronization
bgp log-neighbor-changes
neighbor 209.65.200.226 65002
R2
int s0/0/0encapsulation frame-relay
int s0/0/0.12 point-to-point
ip address 10.1.1.2 255.255.255.252
frame-relay interface dlci 201
int s0/0/0.23 point-to-point
ip address 10.1.1.5 255.255.255.252
frame-relay interface dlci 203
R3
int s0/0/0encapsulation frame-relay
int s0/0/0.23 point-to-point
ip address 10.1.1.6 255.255.255.252
frame-relay interface dlci 302
int s0/0/0.34 point-to-point
ip address 10.1.1.9 255.255.255.252
frame-relay interface dlci 304
R4
int s0/0/0encapsulation frame-relay
int s0/0/0.34 point-to-point
ip address 10.1.1.10 255.255.255.252
frame-relay interface dlci 302
int f0/0/0
ip address 10.1.4.5 255.255.255.252
int f0/0/1
ip address 10.1.4.9 255.255.255.252
router eigrp 10
no auto-summary
network 10.0.0.0
DSW1
interface f1/0/1ip address 10.1.4.6 255.255.255.0
interface f1/0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
interface f1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
interface f1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 14 mode on
interface f1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 14 mode on
interface f1/0/23
no switchport
no ip address
channel-group 12 mode on
interface f1/0/24
no switchport
no ip address
channel-group 12 mode on
interface vlan 10
ip address 10.2.1.1 255.255.255.0
standby 10 ip 10.2.1.254
interface vlan 20
ip address 10.2.2.2 255.255.255.0
interface vlan 200
ip address 192.168.1.129 255.255.255.224
ip dhcp excluded-address 10.1.2.1 10.1.2.2
ip dhcp pool DHCP_POOL
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
router eigrp 10
no auto-summary
network 10.0.0.0
DSW2
interface f1/0/14ip address 10.1.4.10 255.255.255.0
interface f1/0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 24 mode on
interface f1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 24 mode on
nterface f1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
interface f1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
interface f1/0/23
no switchport
no ip address
channel-group 12 mode on
interface f1/0/24
no switchport
no ip address
channel-group 12 mode on
interface vlan 10
ip address 10.2.1.2 255.255.255.0
standby 10 ip 10.2.1.254
standby 10 priority 90
interface vlan 20
ip address 10.2.2.1 255.255.255.0
interface vlan 200
ip address 192.168.1.130 255.255.255.224
router eigrp 10
no auto-summary
network 10.0.0.0
ASW1
interface f1/0/19switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
interface f1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 13 mode on
interface f1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
interface f1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,200
channel-group 23 mode on
int f1/0/1
switchport mode access
switchport access vlan 10
switchport port-security
int f1/0/2
switchport mode access
switchport access vlan 10
switchport port-security
ip access-list 10 permit 10.2.0.0 255.255.255.0
vlan access-map BLOCK_CLIENT1 10
action drop
match ip ACL_BLOCK_CLIENT1
vlan access-map BLOCK_CLIENT1 20
action forward
vlan filter BLOCK_CLIENT1 vlan_list 10
ASW2
interface f1/0/19switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 13 mode on
interface f1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 13 mode on
interface f1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 23 mode on
interface f1/0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 20,200
channel-group 23 mode on
int f1/0/1
switchport mode access
switchport access vlan 20
This configuration can help you to prepare for the Cisco TSHOOT exam. Please, if you see any mistake, let me know.
No comments:
Post a Comment